Increased latency

Incident Report for Trainual

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 20:44 UTC

Investigating

We are investigating an issue with increased latency and delayed background processing.
Posted Aug 27, 2025 - 20:02 UTC
This incident affected: Web Application.